Shakepay

Status

ETH Cashouts Delayed
Incident Report for Shakepay
Resolved
This incident has been resolved.
Posted May 04, 2021 - 16:04 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 04, 2021 - 13:23 EDT
Investigating
We are currently investigating this issue.
Posted May 04, 2021 - 12:56 EDT
This incident affected: Cashouts (Ethereum cashouts).