Shakepay

Status

CAD Cashout Delayed
Incident Report for Shakepay
Resolved
This incident has been resolved.
Posted Aug 26, 2021 - 14:45 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 26, 2021 - 11:54 EDT
Investigating
We are currently investigating this issue.
Posted Aug 26, 2021 - 10:55 EDT
This incident affected: Cashouts (Interac e-Transfer cashouts).