Shakepay

Status

ETH Cashins Delayed
Incident Report for Shakepay
Resolved
This incident has been resolved.
Posted Jul 08, 2021 - 14:45 EDT
Identified
We are aware of the situation and are currently implementing a fix. Pending transactions will get processed as soon as possible.
Posted Jul 08, 2021 - 11:41 EDT
This incident affected: Funding (Ethereum funding).