Shakepay

Status

BTC Cashouts Delay
Incident Report for Shakepay
Resolved
This incident has been resolved.
Posted Apr 20, 2021 - 15:29 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 20, 2021 - 14:46 EDT
This incident affected: Cashouts (Bitcoin cashouts).