Shakepay

Status

ETH cash out
Incident Report for Shakepay
Resolved
This incident has been resolved.
Posted Dec 04, 2021 - 10:46 EST
Update
We are continuing to investigate this issue.
Posted Dec 04, 2021 - 10:46 EST
Investigating
We are currently investigating this issue.
Posted Dec 04, 2021 - 08:24 EST
This incident affected: Cashouts (Ethereum cashouts).