Shakepay

Status

eTransfer Cashouts Delayed
Incident Report for Shakepay
Resolved
This incident has been resolved.
Posted Jun 14, 2022 - 20:29 EDT
Investigating
We are currently investigating this issue.
Posted Jun 14, 2022 - 19:52 EDT
This incident affected: Cashouts (Interac e-Transfer cashouts).