Shakepay

Status

ETH Cashouts Delayed
Incident Report for Shakepay
Resolved
This incident has been resolved.
Posted Jul 22, 2021 - 16:50 EDT
Investigating
We are currently investigating this issue.
Posted Jul 22, 2021 - 16:31 EDT
This incident affected: Cashouts (Ethereum cashouts).