Shakepay

Status

ETH Cashins Delayed
Incident Report for Shakepay
Resolved
This incident has been resolved.
Posted Sep 15, 2022 - 17:14 EDT
Monitoring
We're currently processing incoming ETH transactions and catching up with the network post-merge. Thank you for your patience.
Posted Sep 15, 2022 - 10:27 EDT
This incident affected: Funding (Ethereum funding).