Shakepay

Status

BTC cashouts delayed
Incident Report for Shakepay
Resolved
This incident has been resolved and all pending transactions have been processed.
Posted Apr 23, 2021 - 08:51 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 23, 2021 - 05:58 EDT
This incident affected: Cashouts (Bitcoin cashouts).