Shakepay

Status

ETH Cashouts under maintenance
Incident Report for Shakepay
Resolved
This incident has been resolved.
Posted May 22, 2022 - 09:04 EDT
Monitoring
Our ETH cashouts processor is currently undergoing maintenance - Service will be resumed around 9AM EST and transactions will be processed then.
Posted May 22, 2022 - 08:02 EDT
This incident affected: Cashouts (Ethereum cashouts).