Back to shakepay.com
Shakepay
Status
x
Visit our
support site
.
Get the
Atom Feed
or
RSS Feed
.
Crypto (BTC/ETH) Transactions Delayed
Incident Report for
Shakepay
Resolved
This incident has been resolved.
Posted
May
31
,
2024
-
18:27
EDT
Monitoring
A fix has been implemented and the backlog of transactions is being processed.
Posted
May
31
,
2024
-
18:23
EDT
Identified
The issue has been identified and a fix is being implemented.
Posted
May
31
,
2024
-
17:18
EDT
This incident affected: Cashouts (Bitcoin cashouts, Ethereum cashouts) and Funding (Bitcoin funding, Ethereum funding).
×
Subscribe to Incident
Subscribe to updates for
Crypto (BTC/ETH) Transactions Delayed
via . You'll receive .