Shakepay

Status

Degraded Performance with Interac Money Requests and Ethereum Funding

Incident Report for Shakepay

Resolved

This incident has been resolved.
Posted Nov 11, 2025 - 19:31 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 11, 2025 - 19:16 EST

Update

We are continuing to investigate this issue.
Posted Nov 11, 2025 - 18:37 EST

Investigating

We’re currently experiencing delays with Interac e-Transfer money requests and USDC to USD conversions. The issue has been identified, and a fix is being rolled out.

Thank you for your patience while we work to resolve this.
Posted Nov 11, 2025 - 17:44 EST
This incident affected: Funding (Interac e-Transfer funding, Ethereum funding).