Back to shakepay.com
Shakepay
Status
x
Visit our
support site
.
Get the
Atom Feed
or
RSS Feed
.
Bill Payments and Payees service degraded
Incident Report for
Shakepay
Resolved
This incident has been resolved.
Posted
Jul
19
,
2024
-
10:49
EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Jul
19
,
2024
-
10:44
EDT
Identified
The issue has been identified and a fix is being implemented.
Posted
Jul
18
,
2024
-
19:24
EDT
Investigating
We're aware of an ongoing issue with creating some new Bill Payments and adding or modifying some Bill Payees.
Posted
Jul
18
,
2024
-
18:58
EDT
×
Subscribe to Incident
Subscribe to updates for
Bill Payments and Payees service degraded
via . You'll receive .