Shakepay

Status

ETH Cashouts Delayed
Incident Report for Shakepay
Resolved
This incident has been resolved.
Posted May 19, 2021 - 12:14 EDT
Identified
A spike in the network gas fees is currently affecting ETH transactions. All pending transactions will be broadcasted as soon as possible.
Posted May 19, 2021 - 09:08 EDT
This incident affected: Cashouts (Ethereum cashouts).