Shakepay

Status

USDC Cashout Delayed

Incident Report for Shakepay

Resolved

This incident has been resolved.
Posted Nov 03, 2025 - 19:12 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 03, 2025 - 19:10 EST

Identified

We've identified an issue preventing USDC cashout from the app.

We're working on a fix - Estimated time of resolution is 7:15 PM ET.

Thank you for your patience
Posted Nov 03, 2025 - 18:39 EST
This incident affected: Cashouts (Ethereum cashouts).