A fix has been implemented and we are monitoring the results.
Posted May 30, 2025 - 13:32 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 30, 2025 - 12:44 EDT
Investigating
We are currently investigating an issue affecting the signup process on Shakepay. Some users are reporting that valid email addresses are being rejected during signup.
Thank you for your patience
Posted May 30, 2025 - 12:38 EDT
This incident affected: General (Website, Mobile apps).