Back to shakepay.com
Shakepay
Status
x
Visit our
support site
.
Get the
Atom Feed
or
RSS Feed
.
Shakepay Card Details
Incident Report for
Shakepay
Resolved
This incident has been resolved.
Posted
Jul
15
,
2024
-
18:28
EDT
Identified
An ongoing issue with our card partner currently is preventing users from revealing their Shakepay Card numbers in the mobile application.
Thank you for your patience they address the situation.
Posted
Jul
15
,
2024
-
18:05
EDT
×
Subscribe to Incident
Subscribe to updates for
Shakepay Card Details
via . You'll receive .