This incident has been resolved and all transaction we're broadcasted.
Posted Jul 12, 2025 - 17:50 EDT
Monitoring
A fix has been implemented and we're processing the backlog of transactions.
Thank you for your patience
Posted Jul 12, 2025 - 17:29 EDT
Identified
An issue with a third party provider is currently delaying the processing of Bitcoin cashins and cashouts - Thank you for your patience while we address the situation.
Posted Jul 12, 2025 - 17:22 EDT
This incident affected: Cashouts (Bitcoin cashouts) and Funding (Bitcoin funding).