Verification is currently underway for the maintenance items.
Posted Nov 20, 2025 - 02:13 EST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 20, 2025 - 02:00 EST
Scheduled
Thursday, November 20th, at 2:00 AM, we will be performing a scheduled database maintenance.
All services will be unavailable during this short timeframe (approximately 30 minutes).
We will keep this status page current with live updates.
Once completed, the backlog of pending transfers that take place during the maintenance will be processed normally.
Posted Nov 17, 2025 - 14:31 EST
This scheduled maintenance affected: Funding (Interac e-Transfer funding, Bitcoin funding, Ethereum funding, Wire transfer funding), Cashouts (Interac e-Transfer cashouts, Bitcoin cashouts, Ethereum cashouts, Wire transfer cashouts, Bill Payment), General (Website, Mobile apps, Authentication), and Buy and sell.