Back to shakepay.com
Shakepay
Status
x
Visit our
support site
.
Get the
Atom Feed
or
RSS Feed
.
Delayed BTC cashins
Incident Report for
Shakepay
Resolved
This incident has been resolved.
Posted
Apr
23
,
2025
-
18:52
EDT
Investigating
We are seeing longer than usual delays for BTC cashins, and are investigating the issue.
Pending transactions will be processed once the incident was resolved.
Posted
Apr
23
,
2025
-
15:05
EDT
This incident affected: Funding (Bitcoin funding).
×
Subscribe to Incident
Subscribe to updates for
Delayed BTC cashins
via . You'll receive .