Shakepay

Status

Android & iOS Application Update (1.7.2)
Incident Report for Shakepay
Resolved
This incident has been resolved.
Posted Jun 07, 2021 - 13:54 EDT
Monitoring
Please update to the latest version of the app (1.7.2) to make sure your account is up-to-date and avoid any delays processing your latest transactions.
Posted Jun 06, 2021 - 11:43 EDT
This incident affected: General (Website, Mobile apps).