Shakepay

Status

BTC - Delayed Confirmations
Incident Report for Shakepay
Resolved
This incident has been resolved.
Posted Feb 03, 2022 - 18:01 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 03, 2022 - 17:33 EST
Investigating
We are currently investigating this issue - Transactions will get credited as soon as possible
Posted Feb 03, 2022 - 17:05 EST
This incident affected: Funding (Bitcoin funding).