Shakepay

Status

ETH Cashouts Delayed
Incident Report for Shakepay
Resolved
This incident has been resolved.
Posted Aug 12, 2021 - 19:20 EDT
Investigating
Elevated fees on the blockchain are currently delaying the broadcasting of cashout operations.
Posted Aug 12, 2021 - 17:55 EDT
This incident affected: Cashouts (Ethereum cashouts).