Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 23, 2025 - 03:00 EST
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 21, 2025 - 12:53 EST
Scheduled
Due to a scheduled maintenance from our banking partner, e-Transfer deposits and withdrawals will be unavailable Sunday, February 23rd between 3:00 am - 5:30 am EDT. Full functionality will be restored at that point and transfers will be processed then.
Posted Feb 21, 2025 - 12:39 EST
This scheduled maintenance affected: Funding (Interac e-Transfer funding) and Cashouts (Interac e-Transfer cashouts).