Back to shakepay.com
Shakepay
Status
x
Visit our
support site
.
Get the
Atom Feed
or
RSS Feed
.
Shakepay Card - VISA network
Incident Report for
Shakepay
Resolved
This incident has been resolved.
Posted
Aug
08
,
2024
-
10:47
EDT
Identified
We are continuing to monitor an issue with a provider's connection to VISA network.
Posted
Aug
08
,
2024
-
10:37
EDT
×
Subscribe to Incident
Subscribe to updates for
Shakepay Card - VISA network
via . You'll receive .