Shakepay

Status

ETH Cashouts Delayed
Incident Report for Shakepay
Resolved
This incident has been resolved.
Posted Aug 19, 2021 - 15:20 EDT
Investigating
We are currently investigating this issue.
Posted Aug 19, 2021 - 15:12 EDT
This incident affected: Cashouts (Ethereum cashouts).