Shakepay

Status

Service Disruption: Customer Support Chat Unavailable
Incident Report for Shakepay
Resolved
This incident has been resolved.
Posted May 29, 2024 - 13:42 EDT
Monitoring
We regret to inform you that our customer service platform is currently experiencing issues beyond our control. As a result, we are temporarily unable to assist you through our usual support channels. We are closely monitoring the situation and will provide updates as soon as the service is restored. Thank you for your understanding and patience.
Posted May 29, 2024 - 11:11 EDT
This incident affected: General (Website, Mobile apps).