Shakepay

Status

Delayed BTC cashins

Incident Report for Shakepay

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 14:23 EDT

Investigating

We are seeing longer than usual delays for BTC cashins, and are investigating the issue.
Pending transactions will be processed once the incident was resolved.
Posted Apr 23, 2025 - 13:32 EDT
This incident affected: Funding (Bitcoin funding).