Shakepay

Status

Customer Support Response Time

Incident Report for Shakepay

Resolved

This incident has been resolved.
Posted Jan 04, 2024 - 09:55 EST

Identified

Our customer support response times are currently higher than normal.

Sorry for the inconvenience, we greatly appreciate your patience as we work to get back to you.
Posted Dec 14, 2023 - 12:22 EST
This incident affected: General (Website, Mobile apps).