Shakepay

Status

Service temporarily unavailable
Incident Report for Shakepay
Resolved
This incident has been resolved
Posted Jul 02, 2021 - 11:37 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2021 - 11:36 EDT
Investigating
We are currently investigating this issue.
Posted Jul 02, 2021 - 11:33 EDT
This incident affected: General (Website, Mobile apps).